Hajo's Excelzeiten mit einer umfangreiche Beispielsammlung zum kostenfreien Download. 
			Sowohl Formellösungen als auch Beispiele für die Makroprogrammierung in Excel.
Home
VBA Beispiele
ohne VBA Beispiele

  Allgemein
  Buchstabenanzahl
  Datumswerte
  DropDown-Listenfeld
  Indirekt
  Zellformate

fremde Dateien
Hinweise zu Excel ab Version 2007
Übersicht Downloads
Bilder
Kontakt
Favoriten
Mein Heim-Forum
Tools Tabelle Forum
Impressum
Copyright
Disclaimer

letzte Bearbeitung 07.11.17

Valid XHTML 1.0 Strict CSS ist valide!
Bing
Suchmaschinenoptimierung mit Ranking-Hits


01

 ABC
1vom:01.01.2011 
2bis:31.01.2011 
3   
4Tag Arbeitsort Bemerkung
501.01.2011SamstagNeujahr
602.01.2011Sonntag 
703.01.2011Montag 
804.01.2011Dienstag 
905.01.2011Mittwoch 
1006.01.2011Donnerstag 
1107.01.2011Freitag 
1208.01.2011Samstag 
1309.01.2011Sonntag 
1410.01.2011Montag 
1511.01.2011Dienstag 
1612.01.2011Mittwoch 
1713.01.2011Donnerstag 
1814.01.2011Freitag 
1915.01.2011Samstag 
2016.01.2011Sonntag 
2117.01.2011Montag 
2218.01.2011Dienstag 
2319.01.2011Mittwoch 
2420.01.2011Donnerstag 
2521.01.2011Freitag 
2622.01.2011Samstag 
2723.01.2011Sonntag 
2824.01.2011Montag 
2925.01.2011Dienstag 
3026.01.2011Mittwoch 
3127.01.2011Donnerstag 
3228.01.2011Freitag 
3329.01.2011Samstag 
3430.01.2011Sonntag 
3531.01.2011Montag 
die bedingte Formatierung Fülleffekte, Symbole, Datenbalken
werden in dieser Tabelle nicht dargestellt

verwendete Formeln
Zelle Formel Bereich N/A
B2=DATUM(JAHR(B1);MONAT(B1)+1;1)-1  
A5=B1  
A6:A35=WENN(A5>=$B$2;"";WENN(A5=0;;A5+1))  
B5:B35=A5  
C5:C35=WENNFEHLER(SVERWEIS(B5;Feiertage;2;0);"")  

definierte Namen  
Name Bezieht sich auf Tabelle Z1S1-Formel
Feiertage=Frei!$B$3:$C$31 =Frei!R3C2:R31C3

Bedingte Formatierung Haupttabelle 1  
Wird angewendet auf   Nr. Bed.  Regeltyp  Operator   Formel1   Formel2   Format Schrift Füll-farbe   Unterstrichen   Schrift- farbe Muster   Muster-farbe Typ Bereich
$A$5:$C$3501.Bed.: Formel ist =WENNFEHLER(SVERWEIS($A5;Feiertage;2;0);"")<>""  16777062         2$A$5:$C$35
$A$5:$C$3502.Bed.: Formel ist =WOCHENTAG($A5;2)>5  5296274         2$A$5:$C$35
Bedingte Formatierung Haupttabelle 2 oberere/unterer Bereich    
Wird angewendet auf   Nr. Bed.  Format Zelle Anhalten Auswahl   Anzeige   Anzahl   Durchschnitt   Typ   Bereich
$A$5:$C$3501.Bed.   Falsch          2$A$5:$C$35
$A$5:$C$3502.Bed.   Falsch          2$A$5:$C$35
Die Bedingungen wurden mit Excel-Version ab 2007 ausgelesen.


Füllfarben und Muster  
Zelle Rot Grün Blau Color Muster Farbe
B1 22722722714935011   
Zellen mit Füllfarbe automatisch werden nicht dargestellt


Frei
 ABC
1Jahr2011 
2 Feiertag im
Bundesland
 
301.01.201101.01.2011Neujahr
406.01.2011 hl. 3 Könige
507.03.2011 Rosenmontag
622.04.201122.04.2011Karfreitag
723.04.2011 Ostersamstag
824.04.201124.04.2011Ostersonntag
925.04.201125.04.2011Ostermontag
1001.05.201101.05.2011Maifeiertag
1102.06.201102.06.2011Christi Himmelfahrt
1208.05.2011 Muttertag
1311.06.2011 Pfingstsamstag
1412.06.201112.06.2011Pfingstsonntag
1513.06.201113.06.2011Pfingstmontag
1623.06.2011 Fronleichnam
1703.10.201103.10.2011Nationalfeiertag
1802.10.2011 Reformationstag laut Hinweis im Forum gibt es noch unterschiede in den Konfesion (evangelich / katolisch)
1931.10.201131.10.2011Reformationstag
2001.11.2011 Allerheiligen
2113.11.2011 Volkstrauertag
2216.11.2011 Buss- und Bettag
2320.11.2011 Totensonntag/Ewigkeitssontag
2427.11.2011 1. Advent
2504.12.2011 2. Advent
2611.12.2011 3. Advent
2718.12.2011 4. Advent
2824.12.2011 hl. Abend
2925.12.201125.12.20111. Weihnachtstag
3026.12.201126.12.20112. Weihnachtstag

verwendete Formeln
Zelle Formel Bereich N/A
B1=JAHR('01'!B1)  
A3=DATWERT("01.01."&B1)  
A4=DATWERT("06.01."&B1)  
A5=A8-48  
A6=A8-2  
A7=A8-1  
A8=DM((TAG(MINUTE(B1/38)/2+55) & ".4." & B1)/7;)*7-WENN(JAHR(1)=1904;5;6)  
A9=A8+1  
A10=DATWERT("01.05."&B1)  
A11=A8+39  
A12=WENN(WOCHENTAG(DATUM(B1;5;1);1)=1;(DATUM(B1;5;1)+7);(DATUM(B1;5;1)-WOCHENTAG(DATUM(B1;5;1)))+15)  
A13=A8+48  
A14=A8+49  
A15=A8+50  
A16=A8+60  
A17=DATWERT("03.10."&B1)  
A18=DATUM(B1;10;1)+7-WOCHENTAG(DATUM(B1;10;1);2)  
A19=DATWERT("31.10."&B1)  
A20=DATWERT("01.11."&B1)  
A21=DATUM(B1;12;25)-WOCHENTAG(DATUM(B1;12;25);2)-35  
A22=DATUM(B1;12;25)-WOCHENTAG(DATUM(B1;12;25);2)-32  
A23=DATUM(B1;12;25)-WOCHENTAG(DATUM(B1;12;25);2)-28  
A24=DATUM($B$1;12;25)-WOCHENTAG(DATUM($B$1;12;25);2)-21  
A25=DATUM($B$1;12;25)-WOCHENTAG(DATUM($B$1;12;25);2)-14  
A26=DATUM($B$1;12;25)-WOCHENTAG(DATUM($B$1;12;25);2)-7  
A27=DATUM($B$1;12;25)-WOCHENTAG(DATUM($B$1;12;25);2)  
A28=DATWERT("24.12."&B1)  
A29=DATWERT("25.12."&B1)  
A30=DATWERT("26.12."&B1)  
B3,B6,B8:B11,B14:B15,B17,B19,B29:B30=A3  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit