Hajo's Excelzeiten mit einer umfangreiche Beispielsammlung zum kostenfreien Download. 
			Sowohl Formellösungen als auch Beispiele für die Makroprogrammierung in Excel.
Home
VBA Beispiele

  Allgemein
  Bilder einfügen
  blinkender Zellinhalt
  Counter
  Datei schließen
  Dateikopie
  Dateiverwaltung
  Datensätze umschreiben
  Datum / Zeit
  DropDown-Listenfeld
  Drucken
  Ersatz bedingte Formatierung
  Füllfarbe
  Kontextmenü
  Markieren
  nur mit Makros
  Sound
  Stoppuhr
  Symbolleiste Formular
  Symbolleiste vor 2007
  Symbolleiste ab 2007
  UserForm

ohne VBA Beispiele
fremde Dateien
Hinweise zu Excel ab Version 2007
Übersicht Downloads
Bilder
Kontakt
Favoriten
Mein Heim-Forum
Tools Tabelle Forum
Impressum
Copyright
Disclaimer

letzte Bearbeitung 08.11.17

Valid XHTML 1.0 Strict CSS ist valide!
Bing
Suchmaschinenoptimierung mit Ranking-Hits


Lotto Auto

 ABCDEFGHIJKLMNOPQR
1'- die Auswertung erfolgt über eine Formel unter Format, Bedingte Formatierung        
2 Rot: Zahl richtig getippt           
3 Blau: Zusatzzahl richtig getippt           
4'- die gezogenen Zahlen werden übers Internet aktualisiert       
5'- Spiel 77 und die Super 6 wird über VBA ausgewertet                 
6                  
7         Trefferformel
von {Boris}
        
8 LottoauswertungSuperzahlTrefferZusatzzahlTrefferGewinnklasseGewinn Ausspielung Samstag 4.11.2017
9      Gesamt0 ZahlenZusatzzahlSuperzahl
10 Tippreihe 191116353647111Nein    306
11 Tippreihe 2911162940490Nein    7Spiel 77Super 6
12 Tippreihe 3911161948490Nein    149525443960011
13 Tippreihe 4911161929490Nein    21  
14 Tippreihe 5911161942490Nein    46  
15 Tippreihe 6911161929420Nein    47  
16 Tippreihe 7911161942440Nein       
17 Tippreihe 8913331936430Nein       
18 Tippreihe 9613332830461Nein       
19 Tippreihe 1033236131472Nein       
20                  
21                  
22                  
23  Spiel 77Klasse Gewinn   Super 6 KlasseGewinn    
24    Gesamt 0    Gesamt0    
25 Spielschein-Nr. 016577815   01. Super 636082      
26 Spielschein-Nr. 025579715   02. Super 6136082      
27 Spielschein-Nr. 031277815   03. Super 6126082      
28 Spielschein-Nr. 041237815   04. Supper 6123082      
29 Spielschein-Nr. 051234815   05. Super 6123482      
30 Spielschein-Nr. 061234515   06. Super 6123452      
31 Spielschein-Nr. 071234565   07. Super 6123456      
32 Spielschein-Nr. 081234567   08. Super 623456      
33 Spielschein-Nr. 092345678   09. Super 6345678      
34 Spielschein-Nr. 103456789   10. Super 6456789      
die bedingte Formatierung Fülleffekte, Symbole, Datenbalken
werden in dieser Tabelle nicht dargestellt
Schriftart wird in dieser Tabelle nicht dargestellt

 verbundene Zellen 
A1:J1
B2:G2
B3:G3
A4:K4
B8:H8
P8:R8
B9:H9
I10:I19
C23: D23
G24:H24
C25: D25
E25:F25
G25:H25
K25:L25
C26: D26
E26:F26
G26:H26
K26:L26
C27: D27
E27:F27
G27:H27
K27:L27
C28: D28
E28:F28
G28:H28
K28:L28
C29: D29
E29:F29
G29:H29
K29:L29
C30: D30
E30:F30
G30:H30
K30:L30
C31: D31
E31:F31
G31:H31
K31:L31
C32: D32
E32:F32
G32:H32
K32:L32
C33: D33
E33:F33
G33:H33
K33:L33
C34: D34
E34:F34
G34:H34
K34:L34

verwendete Formeln
Zelle Formel Bereich N/A
P8,P10=Gewinnzahlen!B3  
Q10=Gewinnzahlen!I5  
R10=Gewinnzahlen!C6  
P11=Gewinnzahlen!C5  
P12=Gewinnzahlen!D5  
Q12=Gewinnzahlen!C8  
R12=Gewinnzahlen!C9  
P13=Gewinnzahlen!E5  
P14=Gewinnzahlen!F5  
P15=Gewinnzahlen!G5  
J10:J19=SUMMENPRODUKT(N(ZÄHLENWENN($P$10:$P$15;C10:H10)>0))  
K10:K19=WENN(ODER(ZÄHLENWENN(C10:H10;$Q$10)>0;$I$10=$Q$10);"Ja";"Nein")  
L10:L19=WENN(J10>=3;J10 &WENN(ZÄHLENWENN(C10:H10;$Q$10)>0;" m. ZZ";"");"")&WENN(J10=6; WENN($I$10=$R$10;" m. SZ";"");"")  
M10:M19=LINKS(WENN(TYP(L10*1)=1;WENN(L10="";"";SVERWEIS(L10*1;Gewinnzahlen!$A$12:$L$19;2;0));WENN(L10="";"";SVERWEIS(L10;Gewinnzahlen!$A$12:$L$19;2;0)));8)  
N10:N19=WENN(TYP(L10*1)=1;WENN(L10="";"";SVERWEIS(L10*1;Gewinnzahlen!$A$12:$N$19;14;0));WENN(L10="";"";SVERWEIS(L10;Gewinnzahlen!$A$12:$N$19;14;0)))  
G24=SUMME(G25:H34)  
N9,N24=SUMME(N10:N19)  
E25:E34=WENN(Spiel77aus(C25)>7;"";"Klasse " & Spiel77aus(C25))  
G25:G34=WENN(E25="";"";SVERWEIS(E25;Gewinnzahlen!$A$23:$N$29;14;0))  
M25:M34=WENN(super6aus(K25)>6;"";"Klasse " & super6aus(K25))  
N25:N34=WENN(M25="";"";SVERWEIS(M25;Gewinnzahlen!$A$33:$N$38;14;0))  

Bedingte Formatierung Haupttabelle 1  
Wird angewendet auf   Nr. Bed.  Regeltyp  Operator   Formel1   Formel2   Format Schrift Füll-farbe   Unterstrichen   Schrift- farbe Muster   Muster-farbe Typ Bereich
$C$10:$H$1901.Bed.: Formel ist =ODER(C10=$P$10;C10=$P$11;C10=$P$12;C10=$P$13;C10=$P$14;C10=$P$15)  255   16777215 Uni   2$C$10:$H$19
$C$10:$H$1902.Bed.: Formel ist =ODER(C10=$Q$10)  12611584   16777215      2$C$10:$H$19
$I$1001.Bed.: Formel ist =ODER(I10=$R$10)  255   16777215      2$I$10
Bedingte Formatierung Haupttabelle 2 oberere/unterer Bereich    
Wird angewendet auf   Nr. Bed.  Format Zelle Anhalten Auswahl   Anzeige   Anzahl   Durchschnitt   Typ   Bereich
$C$10:$H$1901.Bed.   Wahr          2$C$10:$H$19
$C$10:$H$1902.Bed.   Wahr          2$C$10:$H$19
$I$1001.Bed.   Wahr          2$I$10
Die Bedingungen wurden mit Excel-Version ab 2007 ausgelesen.


Füllfarben und Muster  
Zelle Rot Grün Blau Color Muster Farbe
P10: P15, Q10:R10, Q12:R12 19219219212632256   
Zellen mit Füllfarbe automatisch werden nicht dargestellt

Schriftformate  
Zelle Rot Grün Blau Color Stil Unterstreichung Effekte Durchgestrichen Schriftart
B8:H8, B9:H9, B23:B24, C24: D24, E23:F24, G23:H23, I8:N9, J23:K24, L24, M20, M23:N24, O9:R9, P8:R8, Q11:R11     Fett         
C23: D23, G24:H24             
N20     Fett  doppelt    
Zellen mit Schriftformatierung automatisch werden nicht dargestellt


Gewinnzahlen
 ABCDEFGHIJKLMNOP
1 Lottozahlen - Ziehungsergebnisse              
2 und Spiel 77 + Super 6 mit Gewinnquoten              
3 Ausspielung Samstag 4.11.2017              
4 Lottozahlen (6 aus 49)        Druckversion     
5 3714214647   Zahlenfeld 7 × 7     
6 Superzahl6             
7                
8 Spiel 779525443             
9 Super 6960011             
10 Lotto       Gesamteinsatz: 48161263    
11 Gewinnklasse       Anzahl Treffer Gewinn%/Soll *)   
126 m. SZ6 Treffer + SZ       '- 13021585,7'-13021585,7  
1366 Treffer       2 883743,71,55883743,7  
145 m. ZZ5 Treffer + SZ       120 7364,50,747364,5  
1555 Treffer       868 3054,40,923054,4  
164 m. ZZ4 Treffer + SZ       5.182 170,50,9170,5  
1744 Treffer       45757 38,60,9238,6  
183 m. ZZ3 Treffer + SZ       90609 19,50,9419,5  
1933 Treffer       779313 10,20,9810,2  
20 2 Treffer + SZ       664687 51   
21                
22 Spiel 77       Gesamteinsatz: 12574037,5    
23GewinnklGewinnklasse       Anzahl Treffer Gewinn #WERT!7-Stellige Spielschein-Nr. 
24alle 7 Zalle 7 Ziffern       2 577777 5777776-Stellige Spielschein-Nr. 
256 Endzif6 Endziffern       3 77777 777775-Stellige Spielschein-Nr. 
265 Endzif5 Endziffern       49 7777 77774-Stellige Spielschein-Nr. 
274 Endzif4 Endziffern       477 777 7773-Stellige Spielschein-Nr. 
283 Endzif3 Endziffern       4.493 77 772-Stellige Spielschein-Nr. 
292 Endzif2 Endziffern       46256 17 171-Stellige Spielschein-Nr. 
30 1 Endziffern       469712 5    
31                
32 Super 6       Gesamteinsatz: 5282706,25    
33GewinnklGewinnklasse       Anzahl Treffer Gewinn #WERT!6-Stellige Gewinnzahl 
346 Endzif6 Endziffern       2 100000 1000005-Stellige Gewinnzahl 
355 Endzif5 Endziffern       32 6666 66664-Stellige Gewinnzahl 
364 Endzif4 Endziffern       286 666 6663-Stellige Gewinnzahl 
373 Endzif3 Endziffern       3.232 66 662-Stellige Gewinnzahl 
382 Endzif2 Endziffern       33820 6 61-Stellige Gewinnzahl 
39 1 Endziffern       319824 2,5    
40                
41 Alle Angaben ohne Gewähr              
42                
43                
44 *) %/Soll = Quotenqualität der Lottogewinne.              
45                
46 Die Qualität besagt, um wieviel der Lottogewinn über oder unter den Gewinnerwartung (=100%) gelegen hat. Die Gewinnerwartung ist der Betrag, der gemäß der Auschüttungsquote jeder Gewinnklasse statistisch zu erwarten gewesen wäre. Der Gewinn liegt höher, wenn wenige Lottospieler in der Klasse gewinnen und der Ausschüttungsbetrag nur durch wenige Gewinner geteilt werden muss. Der Gewinn ist geringer, wenn viele Lottospieler die Gewinnklasse treffen.              
47 Disclaimer | Datenschutz | Nutzungsbedingungen | Impressum              
48 Besuchen Sie die neue LottoFUXX-Seite: logicland.de/lotto              
49 Webseiten erstellt und programmiert von BABEL Computer Applikationen              

verwendete Formeln
Zelle Formel Bereich N/A
A23:A29,A33:A38=LINKS(B23;8)  
N12:N19,N23:N29,N33:N38=WENN(L12="-";"";WECHSELN(WECHSELN(L12;" ";"");"€";"")*1)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.14 einschl. 64 Bit



' **************************************************************
'  Modul:  DieseArbeitsmappe  Typ = Element der Mappe(Sheet, Workbook, ...)
' **************************************************************

Option Explicit                                     ' Variablendefinition erforderlich

Private Sub Workbook_Open()
    On Error Resume Next                            ' Fehlerbehandlung abschalten
    ActiveWorkbook.RefreshAll                       ' Verknüfungen aktualisieren
    On Error GoTo 0                                 ' Falerbehandlung einschalten
End Sub



' **************************************************************
'  Modul:  mdl_Auswertung  Typ = Allgemeines Modul
' **************************************************************

Option Explicit                                     ' Variablendefinition erforderlich

Function Spiel77Aus(RaZelle As Range)
    Dim InI As Integer
    For InI = 7 To 1 Step -1
        If Mid(Format(RaZelle, "0000000"), InI, 1) <> Mid(Format(Range("Spiel77"), "0000000"), InI, 1) Then
            Exit For
        End If
    Next InI
    Spiel77Aus = InI + 1
End Function

Function Super6Aus(RaZelle As Range)
    Dim InI As Integer
    For InI = 6 To 1 Step -1
        If Mid(Format(RaZelle, "000000"), InI, 1) <> Mid(Format(Range("Super6"), "000000"), InI, 1) Then
            Exit For
        End If
    Next InI
    Super6Aus = InI + 1
End Function


Code eingefügt mit: Excel Code Jeanie, angepasrt an XHTML